Strict Standards: mktime(): You should be using the time() function instead in /home/unijimpe/forum.unijimpe.net/extensions/FeedReader/Goo/Goo.Cache.php on line 89
unijimpe forum - Pasando parámetros al WP-SWFObject
Not signed in (Sign In)

Categories

Bienvenido, Visitante

Desea participar en estas discusiones?
Puede iniciar sesión si tiene
una cuenta, o registrarse ahora.

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorllops
    • CommentTimeNov 5th 2007
     
    Buenas!
    Primero de todo felicitarte por el plugin, es genial. Y ahora mi problema:

    estoy intentando pasar 2 variables a la película de la siguiente forma:
    [SWF]productos.swf, 400, 300, model=v8&url_images=imgs/[/SWF]

    El flash me carga, pero no le llega la ruta de la imágenes. Miro el código fuente y encuentro lo siguiente:
    vswf.addVariable("model", "v8");
    vswf.addVariable("#038;url_images", "imgs/");

    Lo curioso es que el ampersand lo coge bien, ya que me crea las 2 variables, pero me "ensucia" las que llevan el &.
    ¿ Alguna idea de porque adjunta el #38; ?

    Muchas gracias por tu tiempo.
    Saludos!
  1.  
    wp-swfobject.php ->

    Trabalho com JAVA, mais entendo bem PHP e como uso WORPRESS e precisei usar o plugin, resolvi o problema desta maneira:

    //////// ANTES:
    if ($match[4] != "") {
    parse_str(trim(substr($match[4],1)), $params);
    foreach ($params as $param => $value) {
    $writeswf.= "vswf.addVariable(\"".$param."\", \"".$value."\");\n";
    }
    }

    ////////// DEPOIS:
    if ($match[4] != "") {
    $aleParam = ereg_replace("amp;","",$match[4]);
    parse_str(trim(substr($aleParam,1)), $params);
    foreach ($params as $param => $value) {
    $writeswf.= "vswf.addVariable(\"".$param."\", \"".$value."\");\n";
    }
    }


    Saludos!