Strict Standards: mktime(): You should be using the time() function instead in /home/unijimpe/forum.unijimpe.net/extensions/FeedReader/Goo/Goo.Cache.php on line 89

Strict Standards: Only variables should be passed by reference in /home/unijimpe/forum.unijimpe.net/extensions/Attachments/default.php on line 174
unijimpe forum - Bugs de WP-SWFObject
Not signed in (Sign In)

Categories

Bienvenido, Visitante

Desea participar en estas discusiones?
Puede iniciar sesión si tiene
una cuenta, o registrarse ahora.

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthoradmin
    • CommentTimeFeb 28th 2007
     
    Si también lo he revisado y el error continua, me parece que es un problema de interferencia entre scripts, tienes varios plugins que utilizan diferentes librerías javascript y agregarle una mas puede ser la causa de que ocurra este error.
    • CommentAuthoradmin
    • CommentTimeFeb 28th 2007
     
    josexxxe he visto tu pagina y parece que no tiene el archivo swfobject.js, este archivo debe estar en la carpeta: wp-content/plugins/swfobject.js es decir el mismo lugar donde pusiste wp-swfobject.php. Con eso funcionará correctamente el plugin.

    Saludos.
    • CommentAuthorRobot04
    • CommentTimeMar 4th 2007
     
    Ok, muchísimas gracias de nuevo... probaré a desactivar los otros plugins, y ya te contaré
    • CommentAuthorRobot04
    • CommentTimeMar 4th 2007
     
    Unijimpe no se si lo que digo es una chorrada, pero al meter el swfobject en una carpeta dentro de la carpeta plugins creo que ha dejado de ocurrir el problema, aunque claro... tampoco funcionaba el plugin... quizá esa podría ser una solución? no tengo mucha idea de programación así que no se como se podría hacer para que funcionase...
    Crees que puede tener algún sentido?
    • CommentAuthorunijimpe
    • CommentTimeMar 4th 2007
     
    la verdad todo es posible, déjame revisar ese punto y a ver si logro corregir ese tema.
    • CommentAuthorsilvio_222
    • CommentTimeJul 20th 2007
     
    Unijimpe, tengo la version 1.5, funciona bien en IE pero en Firefox 2.0.0.5 no muestra el swf.
    Tengo el swfobject.js en la carpeta "includes", y el swf tambien.
    Lo raro es que en IE funciona bien.
    Puede ayudarme? Gracias.

    Saludos
    • CommentAuthorunijimpe
    • CommentTimeJul 22nd 2007
     
    Hola silvio_222 si me das la ruta de tu web puedo ayudarte a encontrar la solución a tu problema.
    • CommentAuthordale
    • CommentTimeOct 4th 2007
     
    Hola, creo que he encontrado un pequeño bug. El plugin me funciona perfectamente desde hace tiempo, pero me he dado cuenta que en las páginas que son resultados de búsquedas, no me funciona.

    Mira la diferencia entre http://dalealteclado.com/?s=manu+chao
    y http://dalealteclado.com/2007/06/rainin-in-paradize-adelanto-de-lo-ultimo-de-manu-chao-video.html

    Quizás pueda ser un problema de mi tema, pero me da a mi que no.

    Gracias por el plugin y por tu ayuda. Un saludo.
    • CommentAuthorsbustelo
    • CommentTimeDec 20th 2007
     
    Resolví el error "Internet Explorer no puede abrir el sitio"!

    Explorer tiene problemas con scripts que modifican el DOM cuando la página aún no terminó de cargar. Esa es la pólvora; la detonación se produce cuando está instalada la librería mootools.

    Para solucionarlo, es necesario "diferir" la ejecución de los <script> que reemplazan los DIVs "vacíos" por <object>s. El atributo defer="defer" sería teóricamente una solución, pero en la práctica, IE vuelve a sorprendernos...

    Por lo que nos queda es, en caso de estar instalada la librería mootools, encapsular el código del script en una función anónima a ser ejecutada por el evento "domready" de mootools.
    La desventaja de este método (al igual que usar el "defer", si funcionara), es que los DIVs no serán reemplazados por <object>s hasta que no haya terminado de cargar la página.
    Para que no resulte molesto, podemos definir a esos DIVs el ancho y alto de los elementos Flash, y un class que nos permita ponerles un "spinner" o similar a gusto.

    Aquí están las partes del código en cuestión, con /* fix */ encabezando las líneas modificadas o nuevas:

    /* fix */ $writeswf.= "<div id=\"swf".$idrnd."_".$flashcont.
    "\" class=\"swf\" style=\"width:" . $match[2] .
    "px; height:" . $match[3] . "px;\"></div>\n";
    $writeswf.= "<script type=\"text/javascript\"><!--\n";

    /* fix */ $writeswf.= "window.addEvent('domready', function(){\n"; //ejecutaremos el script en domready

    $writeswf.= "var vswf = new SWFObject(\""...

    (...)

    $writeswf.= "vswf.write(\"swf".$idrnd."_".$flashcont."\");\n";

    /* fix */ $writeswf.= "});\n"; // cerramos domready
    $writeswf.= "// --></script>\n";



    Las líneas que abren y cierran el script para el domready deberían, desde luego, aparecer sólo si se ha podido detectar mootools o el usuario ha tildado alguna opción a tal efecto.

    Saludos!

    --
    Santiago Bustelo
    diseño / desarrollo
    • CommentAuthorckcobono
    • CommentTimeDec 21st 2007 edited
     
    muchas gracias por poner disponible el reproductor tipo youtube
    va link en mi blog
    gracias